HR Down
Incident Report for Basecamp
Resolved
This incident has been resolved.
Posted Jun 29, 2021 - 20:14 UTC
Update
Looks like Highrise is back up. We're still here monitoring the issues just in case. We're so sorry everyone.
Posted Jun 29, 2021 - 20:14 UTC
Investigating
Highrise is currently unavailable, but we're digging in to fix. Hang tight. Sorry for the disruption, everyone.
Posted Jun 29, 2021 - 20:11 UTC
This incident affected: Highrise.