Highrise outage
Incident Report for Basecamp
Resolved
Highrise is back up. We're so sorry for the trouble today.
Posted Sep 08, 2020 - 19:32 UTC
Investigating
Highrise is currently down. We're investigating the cause and will update you as soon as we can. Sorry for the interruption, everyone.
Posted Sep 08, 2020 - 19:28 UTC
This incident affected: Highrise.