Investigating possible Backpack issues
Incident Report for 37signals
Resolved
Backpack is back up, and we’re continuing work to keep it stable. We’re so sorry for the downtime today.
Posted Apr 06, 2020 - 16:45 UTC
Investigating
We have detected possible issues with Backpack. Please stay tuned for updates. We're so sorry for any interruption to your work.
Posted Apr 06, 2020 - 16:45 UTC
This incident affected: Backpack.