HEY is experiencing delays receiving email
Incident Report for Basecamp
Resolved
HEY email receiving is back! We'll continue to monitor it to make sure it's stable. So sorry for the interruption today, folks.
Posted Sep 08, 2020 - 15:19 UTC
Investigating
HEY is currently seeing some delays receiving email . We're investigating the root cause and will provide updates as soon as we can. Sorry for the interruption, everyone.
Posted Sep 08, 2020 - 15:01 UTC
This incident affected: HEY.